net-mail/automx2: amd64 stable wrt bug #721532
[gentoo.git] / net-mail / list-remote-forwards / list-remote-forwards-0.0.1-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 # ebuild generated by hackport 0.4.4
7
8 CABAL_FEATURES="bin test-suite"
9 inherit haskell-cabal
10
11 DESCRIPTION="List all remote forwards for mail accounts stored in a database"
12 HOMEPAGE="http://hackage.haskell.org/package/list-remote-forwards"
13 SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
14
15 LICENSE="GPL-3"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RESTRICT=test # Ambiguous packages: dns-3.0.2 resolv-0.1.1.1
21
22 RDEPEND=""
23 DEPEND="${RDEPEND}
24         >=dev-haskell/cabal-1.16.0
25         >=dev-haskell/cmdargs-0.10
26         >=dev-haskell/configurator-0.2
27         >=dev-haskell/dns-1.4
28         >=dev-haskell/hdbc-2.4
29         >=dev-haskell/hdbc-postgresql-2.3
30         >=dev-haskell/hdbc-sqlite3-2.3
31         >=dev-haskell/missingh-1.2
32         >=dev-haskell/tasty-0.8
33         >=dev-haskell/tasty-hunit-0.8
34         >=dev-haskell/tasty-quickcheck-0.8
35         >=dev-lang/ghc-7.6.1
36         test? ( >=dev-haskell/doctest-0.9
37                 >=dev-haskell/filemanip-0.3.6 )
38 "
39
40 PATCHES=(
41         "${FILESDIR}"/${P}-ghc84.patch
42 )
43
44 src_install() {
45         haskell-cabal_src_install
46         doman "${S}/doc/man1/${PN}.1"
47 }