net-mail/dovecot: security bump to 2.3.10.1
[gentoo.git] / net-mail / libdbx / libdbx-1.0.3.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit eutils toolchain-funcs
7
8 MY_PN="libdbx"
9 MYFILE="${MY_PN}_${PV}.tgz"
10
11 DESCRIPTION="Tools and library for reading Outlook Express mailboxes (.dbx format)"
12 HOMEPAGE="https://sourceforge.net/projects/ol2mbox"
13 SRC_URI="mirror://sourceforge/ol2mbox/${MYFILE}"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 x86"
18 IUSE=""
19
20 S="${WORKDIR}/${MY_PN}_${PV}"
21
22 src_prepare() {
23         epatch "${FILESDIR}/bad_c.patch"
24         sed -i -e 's/-g/$(CFLAGS) $(LDFLAGS)/;s|gcc|$(CC)|g' Makefile || die
25         tc-export CC
26 }
27
28 src_install() {
29         dobin readoe readdbx
30         dodoc README* AUTHORS FILE-FORMAT
31 }