net-mail/mailman: Version bump.
[gentoo.git] / net-mail / imapsync / imapsync-1.836.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 DESCRIPTION="A tool allowing incremental and recursive IMAP transfers between mailboxes"
7 HOMEPAGE="http://ks.lamiral.info/imapsync/ https://github.com/imapsync/imapsync"
8 SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
9
10 LICENSE="WTFPL-2"
11 SLOT="0"
12 KEYWORDS="~amd64 ~ppc ~x86"
13
14 DEPEND="
15         dev-lang/perl"
16
17 RDEPEND="
18         ${DEPEND}
19         dev-perl/Digest-HMAC
20         dev-perl/File-Copy-Recursive
21         dev-perl/IO-Socket-INET6
22         dev-perl/IO-Socket-SSL
23         dev-perl/IO-Tee
24         dev-perl/Mail-IMAPClient
25         dev-perl/Readonly
26         dev-perl/Sys-MemInfo
27         dev-perl/TermReadKey
28         dev-perl/Unicode-String
29         virtual/perl-Digest-MD5
30         virtual/perl-MIME-Base64"
31
32 RESTRICT="test"
33
34 S=${WORKDIR}/${PN}-${P}
35
36 src_prepare() {
37         sed -e "s/^install: testp/install:/" \
38                 -e "/^DO_IT/,/^$/d" \
39                 -i "${S}"/Makefile || die
40
41         default
42 }
43
44 src_compile() { :; }