sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-mail / grepmail / grepmail-5.30.33-r2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit versionator perl-module
7
8 MY_P="${PN}-$(delete_version_separator 2)"
9 S="${WORKDIR}/${MY_P}"
10
11 DESCRIPTION="Search normal or compressed mailbox using a regular expression or dates"
12 HOMEPAGE="https://github.com/coppit/grepmail"
13 SRC_URI="mirror://sourceforge/grepmail/${MY_P}.tar.gz"
14
15 SLOT="0"
16 LICENSE="GPL-2"
17 KEYWORDS="amd64 ppc x86"
18 IUSE="test"
19 RESTRICT="!test? ( test )"
20
21 RDEPEND="
22         dev-perl/Inline
23         dev-perl/TimeDate
24         dev-perl/Date-Manip
25         virtual/perl-Digest-MD5
26         >=dev-perl/Mail-Mbox-MessageParser-1.40.01
27 "
28 DEPEND="${RDEPEND}
29 "
30 #       test? ( dev-perl/Mail-Mbox-MessageParser )
31
32 # 100% failure on running
33 DIST_TEST="skip"
34
35 PATCHES=(
36         "${FILESDIR}"/5.30.33-fix_nonexistent_mailbox_test.patch
37         "${FILESDIR}"/5.30.33-midnight.patch
38 )
39
40 src_prepare() {
41         sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
42                 die "Can't patch Makefile.PL for 5.26 dot-in-inc"
43         perl-module_src_prepare
44 }