net-mail/notmuch: add ~ppc64 keyword
[gentoo.git] / net-mail / getmail / getmail-5.14.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python2_7 )
6 PYTHON_REQ_USE="ssl?"
7
8 inherit distutils-r1
9
10 DESCRIPTION="A mail retriever with reliable Maildir and mbox delivery"
11 HOMEPAGE="http://pyropus.ca/software/getmail/"
12 SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="amd64 ppc x86 ~ppc-macos ~x86-macos ~x64-solaris"
17 IUSE="ssl"
18
19 python_prepare_all() {
20         sed -i -e "s,'getmail-%s' % __version__,'${PF}'," \
21                 -e "/docs\/COPYING/d" "${S}"/setup.py || die
22
23         distutils-r1_python_prepare_all
24 }