net-mail/dovecot: Stable for HPPA (bug #601452).
[gentoo.git] / net-mail / fastforward / fastforward-0.51-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 inherit eutils fixheadtails
6
7 DESCRIPTION="handle qmail forwarding according to a cdb database"
8 HOMEPAGE="http://cr.yp.to/fastforward.html"
9 SRC_URI="http://cr.yp.to/software/${P}.tar.gz"
10
11 LICENSE="public-domain"
12 SLOT="0"
13 KEYWORDS="x86 sparc ~ppc"
14 IUSE=""
15
16 DEPEND="sys-apps/groff"
17
18 src_unpack() {
19         unpack ${A}
20         cd "${S}"
21         epatch "${FILESDIR}/${PV}-errno.patch"
22         ht_fix_file Makefile
23
24         echo "gcc ${CFLAGS}" > conf-cc
25         echo "gcc" > conf-ld
26 }
27
28 src_compile() {
29         emake it || die
30 }
31
32 # make check is actually an install-check target, see bug #283177
33 src_test() { :; }
34
35 src_install() {
36         dodoc ALIASES BLURB CHANGES FILES INSTALL README SYSDEPS TARGETS
37         dodoc THANKS TODO VERSION
38         doman *.1
39
40         insopts -o root -g qmail -m 755
41         insinto /var/qmail/bin
42         doins fastforward newaliases newinclude printforward printmaillist \
43                 setforward setmaillist
44 }