2b677c23353cab8af50744c08c1fe3464c5dc984
[gentoo.git] / net-mail / checkpassword / checkpassword-0.90-r2.ebuild
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 inherit eutils toolchain-funcs flag-o-matic
5
6 DESCRIPTION="A uniform password checking interface for root applications"
7 HOMEPAGE="http://cr.yp.to/checkpwd.html"
8 SRC_URI="http://cr.yp.to/checkpwd/${P}.tar.gz"
9
10 LICENSE="all-rights-reserved"
11 SLOT="0"
12 KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
13 IUSE="static"
14 RESTRICT="mirror bindist"
15
16 src_unpack() {
17         unpack ${A}
18         cd "${S}"
19         epatch "${FILESDIR}"/${PV}-errno.patch
20         epatch "${FILESDIR}"/${PV}-head-1.patch
21
22         use static && append-ldflags -static
23 }
24
25 src_compile() {
26         echo "$(tc-getCC) ${CFLAGS}" > conf-cc
27         echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
28         make || die "Error in make"
29 }
30
31 src_install() {
32         into /
33         dobin checkpassword || die
34         dodoc CHANGES README TODO VERSION FILES SYSDEPS TARGETS
35 }