net-mail/fetchmail: sh stable wrt bug #701938
[gentoo.git] / net-mail / autorespond / autorespond-2.0.5.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Autoresponder add on package for qmailadmin"
7 HOMEPAGE="http://www.inter7.com/software/"
8 SRC_URI="http://qmail.ixip.net/download/${P}.tar.gz"
9
10 LICENSE="GPL-2"
11 SLOT="0"
12 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
13
14 RDEPEND="virtual/qmail"
15 PATCHES=(
16         "${FILESDIR}/${P}-no-include-bounce.patch"
17 )
18 DOCS=( README help_message qmail-auto )
19
20 src_compile() {
21         emake CFLAGS="${CFLAGS}"
22 }
23
24 src_install() {
25         into /var/qmail
26         dobin autorespond
27         doman *.1
28         einstalldocs
29 }
30
31 pkg_postinst() {
32         ewarn "Please note that original messages are now NOT included with bounces"
33         ewarn "by default. Use the flag per the help output if you want them."
34 }