net-mail/offlineimap: restore KEYWORDS to 7.3.3
[gentoo.git] / net-mail / asmail / asmail-2.1-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5
6 inherit toolchain-funcs eutils
7
8 DESCRIPTION="a small mail monitor similar to xbiff"
9 HOMEPAGE="http://www.tigr.net"
10 SRC_URI="http://www.tigr.net/afterstep/download/${PN}/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~ppc x86"
15 IUSE="jpeg libressl"
16
17 RDEPEND="
18         !libressl? ( dev-libs/openssl:0= )
19         libressl? ( dev-libs/libressl:0= )
20         x11-libs/libXext
21         x11-libs/libX11
22         x11-libs/libXpm
23         x11-libs/libICE
24         x11-libs/libSM
25         jpeg? ( virtual/jpeg:= )"
26 DEPEND="${RDEPEND}
27         x11-base/xorg-proto"
28
29 src_prepare() {
30         epatch "${FILESDIR}"/${P}-ldflags.patch
31         sed -i -e "/LIB/s/-lssl/-lssl -lcrypto/g" \
32                 configure
33 }
34
35 src_configure() {
36         tc-export CC
37         econf $(use_enable jpeg)
38 }
39
40 src_install() {
41         dobin ${PN}
42
43         newman ${PN}.man ${PN}.1
44         newman ${PN}rc.man ${PN}rc.5
45
46         insinto /usr/share/${PN}/pixmaps
47         doins pixmaps/cloud-e/*.xpm
48
49         insinto /usr/share/${PN}
50         doins -r sounds
51
52         dodoc ${PN}rc.s* CHANGES *.txt README* TODO
53 }