net-mail/notmuch: Fix runtime dependencies
[gentoo.git] / net-mail / altermime / altermime-0.3.11.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs
7
8 DESCRIPTION=" alterMIME is a small program which is used to alter your mime-encoded mailpacks"
9 HOMEPAGE="https://pldaniels.com/altermime/"
10 SRC_URI="https://www.pldaniels.com/altermime/${P}.tar.gz"
11
12 KEYWORDS="amd64 ppc x86"
13
14 LICENSE="Sendmail"
15 SLOT="0"
16 IUSE=""
17
18 PATCHES=(
19         "${FILESDIR}"/${PN}-0.3.10-MIME_headers-overflow.patch
20         "${FILESDIR}"/${P}-respect-flags.patch
21 )
22
23 src_compile() {
24         emake CC="$(tc-getCC)"
25 }
26
27 src_install() {
28         dobin altermime
29         dodoc CHANGELOG README
30 }