net-libs/zeromq: ia64 stable wrt bug #610992
[gentoo.git] / net-libs / zeromq / zeromq-4.1.1.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=true
7
8 inherit autotools-utils
9
10 DESCRIPTION="A brokerless kernel"
11 HOMEPAGE="http://www.zeromq.org/"
12 SRC_URI="http://download.zeromq.org/${P}.tar.gz"
13
14 LICENSE="LGPL-3"
15 SLOT="0/4"
16 KEYWORDS="amd64 arm hppa ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux"
17 IUSE="pgm static-libs test"
18
19 RDEPEND="
20         dev-libs/libsodium:=
21         pgm? ( =net-libs/openpgm-5.2.122 )"
22 DEPEND="${RDEPEND}
23         sys-apps/util-linux
24         pgm? ( virtual/pkgconfig )"
25
26 src_prepare() {
27         einfo "Removing bundled OpenPGM library"
28         rm -fr "${S}"/foreign/openpgm/libpgm* || die
29         sed \
30                 -e '/libzmq_werror=/s:yes:no:g' \
31                 -i configure.ac || die
32         autotools-utils_src_prepare
33 }
34
35 src_configure() {
36         local myeconfargs=()
37         use pgm && myeconfargs+=( --with-system-pgm ) || myeconfargs+=( --without-pgm )
38         autotools-utils_src_configure
39 }
40
41 src_test() {
42         autotools-utils_src_test -j1
43 }
44
45 src_install() {
46         autotools-utils_src_install
47
48         doman doc/*.[1-9]
49 }