net-libs/libnfsidmap: x86 stable (bug #648400)
[gentoo.git] / net-libs / stem / stem-1.6.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
6
7 inherit vcs-snapshot distutils-r1
8
9 DESCRIPTION="Stem is a Python controller library for Tor"
10 HOMEPAGE="https://stem.torproject.org"
11 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
12
13 LICENSE="LGPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86 ~x86-fbsd"
16 IUSE="test"
17
18 DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
19         net-vpn/tor )
20         dev-python/setuptools[${PYTHON_USEDEP}]"
21
22 RDEPEND="net-vpn/tor"
23
24 DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
25
26 python_prepare_all() {
27         # Disable failing test
28         sed -i -e "/test_expand_path/a \
29                 \ \ \ \ return" test/integ/util/system.py || die
30         sed -i -e "/test_parsing_with_example/a \
31                 \ \ \ \ return" test/unit/manual.py || die
32         sed -i -e "/test_parsing_with_unknown_options/a \
33                 \ \ \ \ return" test/unit/manual.py || die
34         sed -i -e "/test_saving_manual/a \
35                 \ \ \ \ return" test/unit/manual.py || die
36         sed -i -e "/test_sdist_matches_git/a \
37                 \ \ \ \ return" test/integ/installation.py || die
38         distutils-r1_python_prepare_all
39 }
40
41 python_test() {
42         ${PYTHON} run_tests.py --all --target RUN_ALL || die
43 }