net-libs/ldns: Remove py2.7
[gentoo.git] / net-libs / shairplay / shairplay-9999.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 if [[ ${PV} == "9999" ]] ; then
9         inherit git-r3
10         EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
11 else
12         EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
13         SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
14         S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 DESCRIPTION="Apple airplay and raop protocol server"
19 HOMEPAGE="https://github.com/juhovh/shairplay"
20 LICENSE="BSD LGPL-2.1 MIT
21         playfair? ( GPL-3+ )"
22
23 SLOT="0"
24 IUSE="+playfair static-libs"
25
26 DEPEND="
27         net-dns/avahi[mdnsresponder-compat]
28         media-libs/libao
29 "
30
31 RDEPEND="
32         ${DEPEND}
33 "
34
35 src_prepare() {
36         default
37         eautoreconf
38 }
39
40 src_configure() {
41         econf \
42                 $(use_with playfair) \
43                 $(use_enable static-libs static)
44 }
45
46 src_install() {
47         default
48         find "${D}" -name '*.la' -delete || die
49 }