net-libs/ldns: Remove py2.7
[gentoo.git] / net-libs / shairplay / shairplay-0_pre20180824.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 if [[ ${PV} == "9999" ]] ; then
9         inherit git-r3
10         EGIT_REPO_URI="https://github.com/juhovh/${PN}.git"
11 else
12         EGIT_COMMIT="096b61ad14c90169f438e690d096e3fcf87e504e"
13         SRC_URI="https://github.com/juhovh/${PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
14         S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
15         KEYWORDS="~amd64 ~x86"
16 fi
17
18 DESCRIPTION="Apple airplay and raop protocol server"
19 HOMEPAGE="https://github.com/juhovh/shairplay"
20 LICENSE="BSD LGPL-2.1 MIT
21         playfair? ( GPL-3+ )"
22
23 SLOT="0"
24 IUSE="alac +playfair static-libs tools"
25
26 DEPEND="
27         tools? ( media-libs/libao )
28 "
29
30 RDEPEND="
31         alac? (
32                 media-sound/alac_decoder
33                 net-libs/shairplay[tools]
34         )
35         tools? (
36                 dev-libs/openssl:0=
37                 net-dns/avahi[mdnsresponder-compat]
38         )
39 "
40
41 src_prepare() {
42         default
43         eautoreconf
44 }
45
46 src_configure() {
47         econf \
48                 $(use_with playfair) \
49                 $(use_enable static-libs static)
50 }
51
52 src_install() {
53         default
54         find "${D}" -name '*.la' -delete || die
55 }