net-libs/rpcsvc-proto: stable 1.4.1-r1 for ppc, bug #725002
[gentoo.git] / net-libs / rest / rest-0.8.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5 GNOME2_LA_PUNT="yes"
6
7 inherit eutils gnome2 multilib-minimal virtualx
8
9 DESCRIPTION="Helper library for RESTful services"
10 HOMEPAGE="https://wiki.gnome.org/Projects/Librest"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0.7"
14 IUSE="+introspection test"
15 RESTRICT="!test? ( test )"
16 KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~ppc ~ppc64 s390 sparc x86"
17
18 # Coverage testing should not be enabled
19 RDEPEND="
20         app-misc/ca-certificates
21         >=dev-libs/glib-2.24:2[${MULTILIB_USEDEP}]
22         dev-libs/libxml2:2[${MULTILIB_USEDEP}]
23         net-libs/libsoup:2.4[${MULTILIB_USEDEP}]
24         introspection? ( >=dev-libs/gobject-introspection-0.6.7:= )
25 "
26 DEPEND="${RDEPEND}
27         dev-util/glib-utils
28         >=dev-util/gtk-doc-am-1.13
29         >=dev-util/intltool-0.40
30         virtual/pkgconfig[${MULTILIB_USEDEP}]
31         test? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
32 "
33
34 multilib_src_configure() {
35         # gnome support only adds dependency on obsolete libsoup-gnome
36         # https://bugzilla.gnome.org/show_bug.cgi?id=758166
37         ECONF_SOURCE=${S} \
38         gnome2_src_configure \
39                 --disable-static \
40                 --disable-gcov \
41                 --without-gnome \
42                 --with-ca-certificates="${EPREFIX}"/etc/ssl/certs/ca-certificates.crt \
43                 $(multilib_native_use_enable introspection)
44
45         if multilib_is_native_abi; then
46                 ln -s "${S}"/docs/reference/rest/html docs/reference/rest/html || die
47         fi
48 }
49
50 multilib_src_test() {
51         # Tests need dbus
52         virtx emake check
53 }
54
55 multilib_src_compile() {
56         gnome2_src_compile
57 }
58
59 multilib_src_install() {
60         gnome2_src_install
61 }