www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / net-libs / nghttp3 / nghttp3-0_pre20190912.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 CMAKE_ECLASS=cmake
7 inherit cmake-multilib
8
9 if [[ ${PV} == 9999 ]] ; then
10         EGIT_REPO_URI="https://github.com/ngtcp2/nghttp3.git"
11         inherit autotools git-r3
12 else
13         GIT_COMMIT="51379a041174ad953dc6ad437712f3b279f81919"
14         SRC_URI="https://github.com/ngtcp2/nghttp3/archive/${GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
15         S="${WORKDIR}/${PN}-${GIT_COMMIT}"
16         KEYWORDS="~amd64 ~hppa"
17 fi
18
19 DESCRIPTION="HTTP/3 library written in C"
20 HOMEPAGE="https://github.com/ngtcp2/nghttp3/"
21
22 LICENSE="MIT"
23 SLOT="0/0"
24 IUSE="test"
25
26 BDEPEND="virtual/pkgconfig"
27 DEPEND="test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
28 RDEPEND=""
29 RESTRICT="!test? ( test )"
30
31 multilib_src_configure() {
32         local mycmakeargs=(
33                 -DENABLE_LIB_ONLY=ON
34                 -DENABLE_EXAMPLES=OFF
35                 -DCMAKE_DISABLE_FIND_PACKAGE_CUnit=$(usex !test)
36         )
37         cmake_src_configure
38 }
39
40 multilib_src_test() {
41         cmake_build check
42 }