net-libs/rpcsvc-proto: arm stable wrt bug #725002
[gentoo.git] / net-libs / nDPI / nDPI-2.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit autotools eutils ltprune multilib
6
7 DESCRIPTION="Open Source Deep Packet Inspection Software Toolkit"
8 HOMEPAGE="https://www.ntop.org/"
9 SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
10
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="static-libs"
15
16 DEPEND="dev-libs/json-c:=
17         net-libs/libpcap"
18 RDEPEND="${DEPEND}"
19
20 src_prepare() {
21         default
22         eautoreconf
23 }
24
25 src_install() {
26         default
27         if ! use static-libs; then
28                 rm "${D}"/usr/$(get_libdir)/lib${PN,,}.a || die
29         fi
30         prune_libtool_files
31 }