Use https by default
[gentoo.git] / net-libs / libzrtpcpp / libzrtpcpp-4.2.4.ebuild
1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils
8
9 MY_P=ZRTPCPP-${PV}
10
11 DESCRIPTION="GNU RTP stack for the zrtp protocol developed by Phil Zimmermann"
12 HOMEPAGE="http://www.gnutelephony.org/index.php/GNU_ZRTP"
13 # https://github.com/wernerd/ZRTPCPP/releases
14 SRC_URI="https://dev.gentoo.org/~mgorny/dist/${MY_P}.tar.gz"
15
16 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
17 LICENSE="GPL-3"
18 IUSE="sqlite"
19 SLOT="0/4"
20
21 RDEPEND="
22         dev-libs/openssl:0=
23         sqlite? ( dev-db/sqlite:3= )"
24 DEPEND="${RDEPEND}
25         virtual/pkgconfig"
26
27 DOCS=( AUTHORS README.md )
28
29 S=${WORKDIR}/${MY_P}
30
31 src_configure() {
32         # note: building only core since that's what ortp wants
33
34         local mycmakeargs=(
35                 -DCORE_LIB=yes
36                 -DCRYPTO_STANDALONE=no
37                 -DSQLITE=$(usex sqlite)
38         )
39
40         cmake-utils_src_configure
41 }