net-libs/webkit-gtk: amd64 stable wrt bug #712260
[gentoo.git] / net-libs / libsearpc / libsearpc-3.0.8-r3.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 PYTHON_COMPAT=( python2_7 )
6 inherit autotools python-single-r1 vcs-snapshot
7
8 DESCRIPTION="A simple C language RPC framework"
9 HOMEPAGE="https://github.com/haiwen/libsearpc/ http://seafile.com/"
10 #TODO: Use commit hash tarball on next version bump.
11 SRC_URI="https://github.com/haiwen/${PN}/archive/v3.1-latest.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="Apache-2.0"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
18
19 DEPEND="${PYTHON_DEPS}
20         >=dev-libs/glib-2.26.0
21         >=dev-libs/jansson-2.2.1"
22 RDEPEND="${DEPEND}
23         $(python_gen_cond_dep '
24                 dev-python/simplejson[${PYTHON_MULTI_USEDEP}]
25         ')"
26
27 src_prepare() {
28         default
29         sed -i -e "s/(DESTDIR)//" ${PN}.pc.in || die
30         eautoreconf
31 }
32
33 src_install() {
34         default
35         # Remove unnecessary .la files, as recommended by ltprune.eclass
36         find "${ED}" -name '*.la' -delete || die
37         python_fix_shebang "${ED}"usr/bin
38 }