dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / net-libs / librsync / librsync-2.1.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit cmake-utils
7
8 DESCRIPTION="Remote delta-compression library"
9 HOMEPAGE="https://librsync.github.io/"
10 SRC_URI="https://github.com/librsync/librsync/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0/2.1"
14 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
15
16 RDEPEND="
17         dev-libs/popt
18 "
19 DEPEND="${RDEPEND}"
20
21 src_configure() {
22         local mycmakeargs=(
23                 -DUSE_LIBB2=OFF
24         )
25
26         cmake-utils_src_configure
27 }