net-libs/libwebsockets: update version to 4.0.4
[gentoo.git] / net-libs / libqmi / libqmi-1.20.0.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 inherit multilib
7 if [[ ${PV} == "9999" ]] ; then
8         inherit git-r3 autotools
9         EGIT_REPO_URI="https://anongit.freedesktop.org/git/libqmi.git"
10 else
11         KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
12         SRC_URI="https://www.freedesktop.org/software/libqmi/${P}.tar.xz"
13 fi
14
15 DESCRIPTION="Qualcomm MSM (Mobile Station Modem) Interface (QMI) modem protocol helper library"
16 HOMEPAGE="https://cgit.freedesktop.org/libqmi/"
17
18 LICENSE="LGPL-2"
19 SLOT="0/5.1"    # soname of libqmi-glib.so
20 IUSE="doc +mbim static-libs"
21
22 RDEPEND=">=dev-libs/glib-2.32
23         dev-libs/libgudev
24         mbim? ( >=net-libs/libmbim-1.14.0 )"
25 DEPEND="${RDEPEND}
26         doc? ( dev-util/gtk-doc )
27         virtual/pkgconfig"
28 [[ ${PV} == "9999" ]] && DEPEND+=" dev-util/gtk-doc" #469214
29
30 src_prepare() {
31         default
32         [[ -e configure ]] || eautoreconf
33 }
34
35 src_configure() {
36         econf \
37                 --disable-more-warnings \
38                 $(use_enable mbim mbim-qmux) \
39                 $(use_enable static{-libs,}) \
40                 $(use_enable {,gtk-}doc)
41 }
42
43 src_install() {
44         default
45         use static-libs || rm -f "${ED}/usr/$(get_libdir)/${PN}-glib.la"
46 }