net-libs/liblockfile: remove unused patches
[gentoo.git] / net-libs / libprotoident / libprotoident-2.0.14_p1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="A library that performs application layer protocol identification for flows"
8 HOMEPAGE="https://research.wand.net.nz/software/libprotoident.php"
9 SRC_URI="https://github.com/wanduow/${PN}/archive/${PV/_p/-}.tar.gz"
10
11 LICENSE="LGPL-3+"
12 SLOT="0/2"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="static-libs tools"
15
16 DEPEND="
17         >=net-libs/libtrace-4.0.1
18         >=net-libs/libflowmanager-3.0.0
19 "
20 RDEPEND="
21         ${DEPEND}
22 "
23 S=${WORKDIR}/${P/_p/-}
24
25 src_prepare() {
26         default
27
28         sed -i \
29                 -e '/-Werror/d' \
30                 lib/Makefile.am || die
31
32         eautoreconf
33 }
34
35 src_configure() {
36         econf \
37                 $(use_enable static-libs static) \
38                 $(use_with tools)
39 }
40
41 src_install() {
42         default
43         find "${D}" -name '*.la' -delete || die
44 }