net-libs/liblockfile: remove unused patches
[gentoo.git] / net-libs / libprotoident / libprotoident-2.0.13.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A library that performs application layer protocol identification for flows"
7 HOMEPAGE="https://research.wand.net.nz/software/libprotoident.php"
8 SRC_URI="https://research.wand.net.nz/software/${PN}/${P}.tar.gz"
9
10 LICENSE="LGPL-3+"
11 SLOT="0/2"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="static-libs tools"
14
15 DEPEND="
16         >=net-libs/libtrace-4.0.1
17         >=net-libs/libflowmanager-3.0.0
18 "
19 RDEPEND="
20         ${DEPEND}
21 "
22
23 src_prepare() {
24         default
25
26         sed -i \
27                 -e '/-Werror/d' \
28                 lib/Makefile{.am,.in} || die
29 }
30
31 src_configure() {
32         econf \
33                 $(use_enable static-libs static) \
34                 $(use_with tools)
35 }
36
37 src_install() {
38         default
39         find "${D}" -name '*.la' -delete || die
40 }