net-libs/telepathy-logger-qt: fix just introduced ebuild 1st line bug
[gentoo.git] / net-libs / libosmocore / libosmocore-0.8.0.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit autotools eutils
7
8 DESCRIPTION="Utility functions for OsmocomBB, OpenBSC and related projects"
9 HOMEPAGE="http://bb.osmocom.org/trac/wiki/libosmocore"
10
11 if [[ ${PV} == 9999* ]]; then
12         inherit git-r3
13         EGIT_REPO_URI="git://git.osmocom.org/${PN}.git"
14         KEYWORDS=""
15 else
16         SRC_URI="http://cgit.osmocom.org/cgit/libosmocore/snapshot/${P}.tar.bz2"
17         KEYWORDS="~amd64 ~arm ~x86"
18 fi
19
20 LICENSE="GPL-2 LGPL-3"
21 SLOT="0"
22 IUSE="embedded pcsc-lite"
23
24 RDEPEND="embedded? ( sys-libs/talloc )
25         pcsc-lite? ( sys-apps/pcsc-lite )"
26 DEPEND="${RDEPEND}
27         app-doc/doxygen"
28
29 src_prepare() {
30         # set correct version in pkgconfig files
31         sed -i "s/UNKNOWN/${PV}/" git-version-gen || die
32
33         epatch "${FILESDIR}"/${PN}-0.6.0-automake-1.13.patch
34         eautoreconf
35 }
36
37 src_configure() {
38         econf \
39                 $(use_enable embedded) \
40                 $(use_enable pcsc-lite pcsc)
41 }
42
43 src_install() {
44         default
45         # install to correct documentation directory
46         mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
47 }