www-client/google-chrome-unstable: automated update
[gentoo.git] / net-libs / liboping / liboping-1.8.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit base autotools
8
9 DESCRIPTION="C library and ncurses based program to generate ICMP echo requests and ping multiple hosts at once"
10 HOMEPAGE="http://noping.cc/"
11 SRC_URI="http://noping.cc/files/${P}.tar.bz2"
12
13 LICENSE="LGPL-2.1 GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm ~x86"
16 IUSE="perl"
17
18 DEPEND="
19         sys-libs/ncurses
20         perl? ( dev-lang/perl )
21 "
22 RDEPEND=${DEPEND}
23
24 PATCHES=( "${FILESDIR}/${PN}-1.6.2-nouidmagic.patch" )
25
26 src_prepare() {
27         base_src_prepare
28         eautoreconf
29 }
30
31 src_configure() {
32         econf \
33                 $(use_with perl perl-bindings INSTALLDIRS=vendor) \
34                 --disable-static
35 }
36
37 src_install() {
38         default
39         find "${D}" -name '*.la'  -delete || die
40
41         fperms u+s,og-r /usr/bin/oping
42         fperms u+s,og-r /usr/bin/noping
43 }