dev-qt/qtwidgets: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-libs / libnetfilter_queue / libnetfilter_queue-1.0.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit autotools-utils linux-info
6
7 DESCRIPTION="API to packets that have been queued by the kernel packet filter"
8 HOMEPAGE="https://www.netfilter.org/projects/libnetfilter_queue/"
9 SRC_URI="https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ppc ~ppc64 ~sparc x86"
14 IUSE="static-libs"
15
16 RDEPEND="
17         >=net-libs/libmnl-1.0.3
18         >=net-libs/libnfnetlink-0.0.41
19 "
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig"
22
23 CONFIG_CHECK="~NETFILTER_NETLINK_QUEUE"
24
25 pkg_setup() {
26         linux-info_pkg_setup
27         kernel_is lt 2 6 14 && ewarn "requires at least 2.6.14 kernel version"
28 }