net-libs/libwebsockets: update version to 4.0.4
[gentoo.git] / net-libs / libnetfilter_log / libnetfilter_log-1.0.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit linux-info autotools-utils
6
7 DESCRIPTION="interface to packets that have been logged by the kernel packet filter"
8 HOMEPAGE="https://www.netfilter.org/projects/libnetfilter_log/"
9 SRC_URI="https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="amd64 ~ia64 ppc ~sparc x86"
14 IUSE="static-libs"
15
16 RDEPEND=">=net-libs/libnfnetlink-1.0.0"
17 DEPEND="${RDEPEND}
18         virtual/pkgconfig"
19
20 CONFIG_CHECK="~NETFILTER_NETLINK_LOG"
21
22 pkg_setup() {
23         linux-info_pkg_setup
24         kernel_is lt 2 6 14 && die "requires at least 2.6.14 kernel version"
25 }