www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / net-libs / libmrss / libmrss-0.19.2.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="A C-library for parsing and writing RSS 0.91/0.92/1.0/2.0 files or streams"
7 HOMEPAGE="http://www.autistici.org/bakunin/libmrss/doc/"
8 SRC_URI="http://www.autistici.org/bakunin/${PN}/${P}.tar.gz"
9
10 LICENSE="LGPL-2.1"
11 SLOT="0"
12 KEYWORDS="amd64 ~arm ~mips ppc x86"
13 IUSE="doc examples"
14
15 RDEPEND="
16         net-libs/libnxml
17         net-misc/curl"
18 DEPEND="${RDEPEND}"
19 BDEPEND="
20         virtual/pkgconfig
21         doc? ( app-doc/doxygen )"
22
23 # TODO: php-bindings
24
25 src_configure() {
26         econf --disable-static
27 }
28
29 src_compile() {
30         default
31
32         if use doc; then
33                 ebegin "Creating documentation"
34                 doxygen doxy.conf || die "generating docs failed"
35                 # clean out doxygen gunk
36                 rm doc/html/*.{md5,map} || die
37                 HTML_DOCS=( doc/html/. )
38                 eend 0
39         fi
40 }
41
42 src_install() {
43         default
44
45         if use examples; then
46                 docinto test
47                 dodoc test/*.c
48         fi
49
50         # no static archives
51         find "${D}" -name '*.la' -delete || die
52 }