dev-qt: Drop Qt 5.14.1 and vulnerable dev-qt/qtgui
[gentoo.git] / net-libs / libmnl / libmnl-1.0.3-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit toolchain-funcs usr-ldscript
7
8 DESCRIPTION="Minimalistic netlink library"
9 HOMEPAGE="https://netfilter.org/projects/libmnl/"
10 SRC_URI="https://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
11
12 LICENSE="LGPL-2.1"
13 SLOT="0"
14 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux"
15 IUSE="examples static-libs"
16
17 src_configure() {
18         econf $(use_enable static-libs static)
19 }
20
21 src_install() {
22         default
23
24         gen_usr_ldscript -a mnl
25
26         find "${D}" -name '*.la' -delete || die
27
28         if use examples; then
29                 find examples/ -name 'Makefile*' -delete || die
30                 dodoc -r examples/
31                 docompress -x /usr/share/doc/${PF}/examples
32         fi
33 }