dev-cpp/pangomm: stable 2.42.1 for hppa, bug #717144
[gentoo.git] / net-libs / libiscsi / libiscsi-1.18.0.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools
7
8 DESCRIPTION="iscsi client library and utilities"
9 HOMEPAGE="https://github.com/sahlberg/libiscsi"
10 SRC_URI="https://github.com/sahlberg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 SLOT="0"
13 LICENSE="GPL-2 LGPL-2"
14 KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86"
15 IUSE="static-libs"
16
17 RDEPEND="dev-libs/libgcrypt:0="
18 DEPEND="${RDEPEND}"
19
20 src_prepare() {
21         default
22         eautoreconf
23 }
24
25 src_configure() {
26         econf \
27                 --enable-manpages \
28                 --disable-werror \
29                 $(use_enable static-libs static)
30 }
31
32 src_install() {
33         default
34         find "${D}" -name '*.la' -delete || die
35 }