net-libs/rpcsvc-proto: arm stable wrt bug #725002
[gentoo.git] / net-libs / libhtp / libhtp-0.5.33.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools multilib-minimal
7
8 DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
9 HOMEPAGE="https://github.com/OISF/libhtp"
10 SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~mips ~x86"
15 IUSE="debug static-libs"
16
17 RDEPEND="sys-libs/zlib[static-libs?]"
18 DEPEND="${RDEPEND}"
19
20 src_prepare() {
21         default
22         eautoreconf
23 }
24
25 multilib_src_configure() {
26         # The debug configure logic is broken.
27         ECONF_SOURCE=${S} \
28         econf \
29                 $(usex debug '--enable-debug' '') \
30                 $(use_enable static-libs static)
31 }
32
33 multilib_src_install_all() {
34         if ! use static-libs; then
35                 find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
36         fi
37 }