www-client/google-chrome-beta: automated update (84.0.4147.30)
[gentoo.git] / net-libs / libgssglue / libgssglue-0.4-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DESCRIPTION="Exports a gssapi interface which calls other random gssapi libraries"
7 HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
8 SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
9
10 LICENSE="BSD"
11 SLOT="0"
12 KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
13 IUSE=""
14
15 RDEPEND="!app-crypt/libgssapi"
16 DEPEND=""
17
18 PATCHES=(
19         "${FILESDIR}"/${PN}-0.3-protos.patch
20         "${FILESDIR}"/${PN}-0.4-implicit-declarations.patch
21 )
22
23 src_prepare() {
24         default
25         sed -i -e "s,/lib/,/$(get_libdir)/," doc/gssapi_mech.conf #646126
26 }
27
28 src_configure() {
29         # No need to install static libraries, as it uses libdl
30         econf --disable-static
31 }
32
33 src_install() {
34         default
35         find "${D}" -name '*.la' -delete || die
36
37         insinto /etc
38         doins doc/gssapi_mech.conf
39 }