dev-qt/qtwidgets: stable 5.14.2 for ppc, bug #719732
[gentoo.git] / net-libs / libgsasl / libgsasl-1.8.0-r1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit autotools eutils
7
8 DESCRIPTION="The GNU SASL library"
9 HOMEPAGE="https://www.gnu.org/software/gsasl/"
10 SRC_URI="mirror://gnu/${PN/lib}/${P}.tar.gz"
11 LICENSE="GPL-3 LGPL-3"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
14 IUSE="idn gcrypt kerberos nls ntlm static-libs"
15 DEPEND="
16         gcrypt? ( dev-libs/libgcrypt:0 )
17         idn? ( net-dns/libidn )
18         kerberos? ( virtual/krb5 )
19         nls? ( >=sys-devel/gettext-0.18.1 )
20         ntlm? ( net-libs/libntlm )
21 "
22 RDEPEND="${DEPEND}
23         !net-misc/gsasl"
24
25 PATCHES=(
26         "${FILESDIR}/${PN}-gss-extra.patch"
27 )
28
29 src_prepare() {
30         default
31         sed -i -e 's/ -Werror//' configure.ac || die
32         eautoreconf
33 }
34
35 src_configure() {
36         local krb5_impl
37         if use kerberos; then
38                 krb5_impl="--with-gssapi-impl="
39                 krb5_impl+=$(has_version app-crypt/mit-krb5 && echo "mit" || echo "heimdal")
40         fi
41         local myeconfargs=(
42                 $(use_with gcrypt libgcrypt)
43                 $(use_with idn stringprep)
44                 $(use_enable kerberos gssapi)
45                 ${krb5_impl}
46                 $(use_enable nls)
47                 $(use_enable ntlm)
48                 $(use_enable static-libs static)
49         )
50         econf "${myeconfargs[@]}"
51 }
52
53 src_install() {
54         default
55
56         if ! use static-libs; then
57                 rm -f "${D}"/usr/lib*/lib*.la
58         fi
59 }