net-libs/libssh2: arm64 stable (bug #699856)
[gentoo.git] / net-libs / libgfbgraph / libgfbgraph-0.2.3-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="5"
5 GCONF_DEBUG="no"
6 GNOME_ORG_MODULE="gfbgraph"
7
8 inherit gnome2
9
10 DESCRIPTION="A GObject library for Facebook Graph API"
11 HOMEPAGE="https://git.gnome.org/browse/libgfbgraph/"
12
13 LICENSE="LGPL-2.1+"
14 SLOT="0.2"
15 KEYWORDS="amd64 ~arm64 x86"
16 IUSE="+introspection"
17
18 RDEPEND="
19         dev-libs/glib:2
20         dev-libs/json-glib[introspection?]
21         net-libs/libsoup:2.4[introspection?]
22         net-libs/gnome-online-accounts
23         net-libs/rest:0.7[introspection?]
24         introspection? ( >=dev-libs/gobject-introspection-1.30:= )
25 "
26 DEPEND="${RDEPEND}
27         >=dev-util/gtk-doc-am-1.14
28         virtual/pkgconfig
29 "
30
31 # FIXME: most tests seem to fail
32 RESTRICT="test"
33
34 src_configure() {
35         gnome2_src_configure \
36                 --disable-static \
37                 $(use_enable introspection)
38 }
39
40 src_install() {
41         gnome2_src_install
42         # Remove files installed in the wrong place
43         # Also, already done by portage
44         # https://bugzilla.gnome.org/show_bug.cgi?id=752581
45         rm -rf "${ED}"/usr/doc
46 }