xfce-base/exo: Disable GTK+2 support in -r100
[gentoo.git] / net-libs / libesmtp / libesmtp-1.0.6-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 inherit autotools
6
7 DESCRIPTION="lib that implements the client side of the SMTP protocol"
8 HOMEPAGE="http://brianstafford.info/libesmtp/"
9 SRC_URI="http://brianstafford.info/${PN}/${P}.tar.bz2"
10
11 LICENSE="LGPL-2.1 GPL-2"
12 SLOT="0"
13 KEYWORDS="~alpha amd64 ~arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
14 IUSE="debug libressl ntlm ssl static-libs threads"
15
16 RDEPEND="
17         ssl? (
18                 !libressl? ( dev-libs/openssl:0= )
19                 libressl? ( dev-libs/libressl:0= )
20         )"
21 DEPEND="${RDEPEND}"
22 DOCS=( AUTHORS ChangeLog NEWS Notes README TODO )
23 PATCHES=(
24         "${FILESDIR}/${P}-openssl-1.1-api-compatibility.patch"
25 )
26
27 src_prepare() {
28         default
29         eautoreconf
30 }
31
32 src_configure() {
33         econf \
34                 --disable-dependency-tracking \
35                 $(use_enable static-libs static) \
36                 --enable-all \
37                 $(use_enable ntlm) \
38                 $(use_enable threads pthreads) \
39                 $(use_enable debug) \
40                 $(use_with ssl openssl)
41 }
42
43 src_install() {
44         default
45         insinto /usr/share/doc/${PF}/xml
46         doins doc/api.xml
47 }