xfce-base/exo: Disable GTK+2 support in -r100
[gentoo.git] / net-libs / libesmtp / libesmtp-1.0.6-r1.ebuild
1 # Copyright 1999-2018 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5 inherit libtool
6
7 DESCRIPTION="lib that implements the client side of the SMTP protocol"
8 HOMEPAGE="http://brianstafford.info/libesmtp/"
9 SRC_URI="http://brianstafford.info/${PN}/${P}.tar.bz2"
10
11 LICENSE="LGPL-2.1 GPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
14 IUSE="debug ntlm ssl static-libs threads"
15
16 RDEPEND="ssl? ( dev-libs/openssl )"
17 DEPEND="${RDEPEND}"
18
19 src_prepare() {
20         elibtoolize
21 }
22
23 src_configure() {
24         econf \
25                 --disable-dependency-tracking \
26                 $(use_enable static-libs static) \
27                 --enable-all \
28                 $(use_enable ntlm) \
29                 $(use_enable threads pthreads) \
30                 $(use_enable debug) \
31                 $(use_with ssl openssl)
32 }
33
34 src_install() {
35         emake DESTDIR="${D}" install
36         dodoc AUTHORS ChangeLog NEWS Notes README TODO
37         insinto /usr/share/doc/${PF}/xml
38         doins doc/api.xml
39 }