net-libs/libbloom: add arm/arm64 keyword
[gentoo.git] / net-libs / libbloom / libbloom-1.5-r1.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit toolchain-funcs
7
8 DESCRIPTION="A simple and small bloom filter implementation in plain C."
9 HOMEPAGE="https://github.com/jvirkki/libbloom"
10 SRC_URI="https://github.com/jvirkki/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
11
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
15 IUSE=""
16
17 DEPEND=""
18 RDEPEND="${DEPEND}"
19
20 src_compile() {
21         emake CC=$(tc-getCC) BITS=default OPT=
22 }
23
24 src_install() {
25         doheader bloom.h
26         dolib.so build/${PN}.so*
27 }