sys-devel/llvm: Merge "remove CppBackend from 9999"
[gentoo.git] / net-libs / ignition-transport / ignition-transport-1.2.0.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit cmake-utils vcs-snapshot flag-o-matic
8
9 DESCRIPTION="Combines ZeroMQ with Protobufs to create a fast and efficient message passing system"
10 HOMEPAGE="http://ignitionrobotics.org/libraries/transport"
11 SRC_URI="http://gazebosim.org/distributions/ign-transport/releases/${P}.tar.bz2"
12
13 LICENSE="Apache-2.0"
14 SLOT="0/0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 DEPEND="
19         dev-libs/protobuf:=
20         >=net-libs/zeromq-3.2.0:=
21         sys-apps/util-linux
22         net-libs/cppzmq
23 "
24 RDEPEND="${DEPEND}"
25 DEPEND="${DEPEND}
26         virtual/pkgconfig"
27 CMAKE_BUILD_TYPE=RelWithDebInfo
28 PATCHES=( "${FILESDIR}/protobuf3.patch" )
29
30 src_configure() {
31         # upstream appends this conditionally...
32         append-flags "-fPIC"
33         echo "set (CMAKE_C_FLAGS_ALL \"${CXXFLAGS} \${CMAKE_C_FLAGS_ALL}\")" > "${S}/cmake/HostCFlags.cmake"
34         sed -i -e "s/LINK_FLAGS_RELWITHDEBINFO \" \"/LINK_FLAGS_RELWITHDEBINFO \" ${LDFLAGS} \"/" cmake/DefaultCFlags.cmake || die
35         cmake-utils_src_configure
36 }