net-libs/libwebsockets: update version to 4.0.4
[gentoo.git] / net-libs / iax / iax-0.2.2-r3.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 inherit autotools
7
8 DESCRIPTION="IAX (Inter Asterisk eXchange) Library"
9 HOMEPAGE="https://www.asterisk.org/"
10 SRC_URI="https://downloads.asterisk.org/pub/telephony/libiax/${P}.tar.gz"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ppc x86"
15 IUSE="debug snomhack"
16
17 PATCHES=(
18         "${FILESDIR}/${PV}-debug.patch"
19         "${FILESDIR}/${PV}-memset.patch"
20         "${FILESDIR}/${PV}-sandbox.patch"
21 )
22
23 src_prepare() {
24         default
25         eautoreconf
26 }
27
28 src_configure() {
29         econf \
30                 $(use_enable debug extreme-debug) \
31                 $(use_enable snomhack)
32 }