01c06fadfd323876e7d1edab22334e09b90b6e19
[gentoo.git] / net-libs / gupnp-ui / gupnp-ui-0.1.1.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 AUTOTOOLS_AUTORECONF=1
7 AUTOTOOLS_IN_SOURCE_BUILD=1
8
9 inherit autotools-utils
10
11 DESCRIPTION="Collection of simple GTK+ widgets on top of GUPnP"
12 HOMEPAGE="http://gupnp.org"
13 SRC_URI="http://gupnp.org/sources/${PN}/${P}.tar.gz"
14
15 LICENSE="LGPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND="x11-libs/gtk+:2
21         net-libs/gssdp:0/3
22         net-libs/gupnp:0/4"
23 DEPEND="${RDEPEND}
24         virtual/pkgconfig
25         sys-devel/gettext"
26
27 PATCHES=(
28         "${FILESDIR}"/${P}-underlinking.patch
29 )
30
31 src_configure() {
32         econf --disable-gtk-doc
33 }
34
35 src_install() {
36         emake DESTDIR="${D}" install
37         dodoc AUTHORS NEWS README
38 }