net-libs/libmicrohttpd-0.9.49-r0: add alpha keyword
[gentoo.git] / net-libs / gnome-online-accounts / gnome-online-accounts-3.18.4.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 GCONF_DEBUG="yes"
7 GNOME2_LA_PUNT="yes"
8
9 inherit gnome2
10
11 DESCRIPTION="GNOME framework for accessing online accounts"
12 HOMEPAGE="https://wiki.gnome.org/Projects/GnomeOnlineAccounts"
13
14 LICENSE="LGPL-2+"
15 SLOT="0/1"
16 IUSE="gnome +introspection kerberos" # telepathy"
17 KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
18
19 # pango used in goaeditablelabel
20 # libsoup used in goaoauthprovider
21 # goa kerberos provider is incompatible with app-crypt/heimdal, see
22 # https://bugzilla.gnome.org/show_bug.cgi?id=692250
23 # json-glib-0.16 needed for bug #485092
24 RDEPEND="
25         >=dev-libs/glib-2.35:2
26         >=app-crypt/libsecret-0.5
27         >=dev-libs/json-glib-0.16
28         dev-libs/libxml2:2
29         >=net-libs/libsoup-2.42:2.4
30         net-libs/rest:0.7
31         net-libs/telepathy-glib
32         >=net-libs/webkit-gtk-2.7.2:4
33         >=x11-libs/gtk+-3.11.1:3
34         x11-libs/pango
35
36         introspection? ( >=dev-libs/gobject-introspection-0.6.2:= )
37         kerberos? (
38                 app-crypt/gcr:0=
39                 app-crypt/mit-krb5 )
40 "
41 #       telepathy? ( net-libs/telepathy-glib )
42 # goa-daemon can launch gnome-control-center
43 PDEPEND="gnome? ( >=gnome-base/gnome-control-center-3.2[gnome-online-accounts(+)] )"
44
45 DEPEND="${RDEPEND}
46         dev-libs/libxslt
47         >=dev-util/gtk-doc-am-1.3
48         >=dev-util/gdbus-codegen-2.30.0
49         >=dev-util/intltool-0.50.1
50         sys-devel/gettext
51         virtual/pkgconfig
52
53         dev-libs/gobject-introspection-common
54         gnome-base/gnome-common
55 "
56 # eautoreconf needs gobject-introspection-common, gnome-common
57
58 # Due to sub-configure
59 QA_CONFIGURE_OPTIONS=".*"
60
61 src_configure() {
62         # TODO: Give users a way to set the G/FB/Windows Live secrets
63         # telepathy optional support is really a badly done, bug #494456
64         gnome2_src_configure \
65                 --disable-static \
66                 --enable-backend \
67                 --enable-documentation \
68                 --enable-exchange \
69                 --enable-facebook \
70                 --enable-flickr \
71                 --enable-foursquare \
72                 --enable-imap-smtp \
73                 --enable-lastfm \
74                 --enable-media-server \
75                 --enable-owncloud \
76                 --enable-pocket \
77                 --enable-telepathy \
78                 --enable-windows-live \
79                 $(use_enable kerberos)
80                 #$(use_enable telepathy)
81         # gudev & cheese from sub-configure is overriden
82         # by top level configure, and disabled so leave it like that
83 }