autotools.eclass: Merge "support AM_GNU_GETTEXT_REQUIRE_VERSION"
[gentoo.git] / net-libs / enet / enet-1.3.13.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6
7 inherit base
8
9 DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
10 HOMEPAGE="http://enet.bespin.org/"
11 SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="1.3/7"
15 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
16 IUSE="static-libs"
17
18 RDEPEND="!${CATEGORY}/${PN}:0"
19
20 DOCS=( "ChangeLog" "README" )
21
22 src_configure() {
23         econf \
24                 --disable-dependency-tracking \
25                 $(use_enable static-libs static)
26 }
27
28 src_install() {
29         base_src_install
30         if ! use static-libs ; then
31                 find "${D}" -type f -name '*.la' -exec rm {} + || die
32         fi
33 }