net-libs/libqmi: x86 stable wrt bug #601666
[gentoo.git] / net-libs / ccrtp / ccrtp-2.1.2.ebuild
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI=5
6 inherit eutils multilib
7
8 DESCRIPTION="GNU ccRTP is an implementation of RTP, the real-time transport protocol from the IETF"
9 HOMEPAGE="https://www.gnu.org/software/ccrtp/"
10 SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
11
12 KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
13 LICENSE="GPL-2"
14 IUSE="doc"
15 SLOT="0/2"
16
17 RDEPEND=">=dev-cpp/commoncpp2-1.3.0:0=
18         dev-libs/libgcrypt:0=
19         >=dev-libs/ucommon-5.0.0:="
20 DEPEND="${RDEPEND}
21         virtual/pkgconfig
22         doc? ( app-doc/doxygen )"
23
24 src_configure() {
25         econf --disable-static
26 }
27
28 src_install() {
29         default
30         prune_libtool_files
31         use doc && dohtml -r doc/html/*
32 }
33
34 pkg_postinst() {
35         if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.4.so.0 ]] ; then
36                 elog "Please run: revdep-rebuild --library libccrtp1-1.4.so.0"
37         fi
38         if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.5.so.0 ]] ; then
39                 elog "Please run: revdep-rebuild --library libccrtp1-1.5.so.0"
40         fi
41         if [[ -e "${ROOT}"/usr/$(get_libdir)/libccrtp1-1.6.so.0 ]] ; then
42                 elog "Please run: revdep-rebuild --library libccrtp1-1.6.so.0"
43         fi
44 }