net-libs/nghttp2: stable 1.29.0 for ppc64, bug #646100
[gentoo.git] / net-libs / balde-markdown / balde-markdown-0.1.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 if [[ ${PV} = *9999* ]]; then
7         EGIT_REPO_URI="https://github.com/balde/${PN}.git"
8         inherit git-r3 autotools
9 fi
10
11 DESCRIPTION="A balde extension that adds Markdown support"
12 HOMEPAGE="https://github.com/balde/balde-markdown"
13
14 SRC_URI="https://github.com/balde/${PN}/releases/download/v${PV}/${P}.tar.bz2"
15 KEYWORDS="~amd64 ~x86"
16 if [[ ${PV} = *9999* ]]; then
17         SRC_URI=""
18         KEYWORDS=""
19 fi
20
21 LICENSE="LGPL-2"
22 SLOT="0"
23 IUSE="test"
24
25 RDEPEND=">=dev-libs/glib-2.34
26         >=net-libs/balde-0.1
27         app-text/discount"
28
29 DEPEND="${RDEPEND}"
30
31 src_prepare() {
32         [[ ${PV} = *9999* ]] && eautoreconf
33         default
34 }
35
36 src_configure() {
37         econf \
38                 --without-valgrind
39 }