profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / net-irc / quasselgrep / quasselgrep-0_p20170411.ebuild
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 PYTHON_COMPAT=( python2_7 )
7 PYTHON_REQ_USE="sqlite"
8
9 inherit distutils-r1
10
11 MY_COMMIT=502c88bdc7613abb68e868eb520e39ec8a5cf6dd
12
13 DESCRIPTION="Tool for searching quassel logs from the commandline"
14 HOMEPAGE="https://github.com/fish-face/quasselgrep"
15
16 if [[ ${PV} == "9999" ]] ; then
17         EGIT_REPO_URI="https://github.com/fish-face/quasselgrep"
18         inherit git-r3
19 else
20         SRC_URI="https://github.com/fish-face/${PN}/tarball/${MY_COMMIT} -> ${P}.tar.gz"
21         S="${WORKDIR}/fish-face-${PN}-${MY_COMMIT:0:7}"
22         KEYWORDS="~amd64 ~x86"
23 fi
24
25 LICENSE="GPL-2"
26 SLOT="0"
27
28 RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
29         dev-python/pycryptodome[${PYTHON_USEDEP}]
30         >=dev-python/psycopg-2.5.3[${PYTHON_USEDEP}]"
31
32 src_configure() {
33         sed -i 's/pycrypto/pycryptodome/g' "${S}"/setup.py || die "sed failed"
34 }