profiles/arch/arm64: Unmask py3.8+3.9
[gentoo.git] / net-irc / polari / polari-3.30.2.ebuild
1 # Copyright 1999-2019 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5
6 inherit gnome.org gnome2-utils meson xdg
7
8 DESCRIPTION="An IRC client for Gnome"
9 HOMEPAGE="https://wiki.gnome.org/Apps/Polari"
10
11 LICENSE="GPL-2+"
12 SLOT="0"
13 KEYWORDS="amd64 ~arm x86"
14 IUSE="test"
15 RESTRICT="!test? ( test )"
16
17 COMMON_DEPEND="
18         >=dev-libs/glib-2.43.4:2
19         >=x11-libs/gtk+-3.21.6:3[introspection]
20         net-libs/telepathy-glib[introspection]
21         >=dev-libs/gobject-introspection-1.50:=
22         >=dev-libs/gjs-1.53.90
23
24         x11-libs/gdk-pixbuf:2[introspection]
25         >=app-text/gspell-1.4.0[introspection]
26         x11-libs/pango[introspection]
27         app-crypt/libsecret[introspection]
28         net-libs/libsoup:2.4[introspection]
29         net-im/telepathy-logger[introspection]
30 "
31 RDEPEND="${COMMON_DEPEND}
32         >=net-irc/telepathy-idle-0.2
33 "
34 DEPEND="${COMMON_DEPEND}
35         dev-libs/appstream-glib
36         dev-libs/libxml2:2
37         dev-util/itstool
38         >=sys-devel/gettext-0.19.8
39         virtual/pkgconfig
40         test? ( dev-lang/spidermonkey:60 )
41 "
42
43 pkg_postinst() {
44         xdg_pkg_postinst
45         gnome2_icon_cache_update
46         gnome2_schemas_update
47 }
48
49 pkg_postrm() {
50         xdg_pkg_postrm
51         gnome2_icon_cache_update
52         gnome2_schemas_update
53 }