net-irc/weechat: 2.7-r2 stable x86 and amd64
[gentoo.git] / net-irc / cgiirc / cgiirc-0.5.10.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 inherit webapp eutils vcs-clean
7
8 DESCRIPTION="A perl/CGI program to use IRC from a web browser"
9 HOMEPAGE="http://cgiirc.org/"
10 SRC_URI="http://cgiirc.org/releases/${P}.tar.gz"
11
12 LICENSE="GPL-2"
13 KEYWORDS="~amd64 ~ppc ~x86"
14 IUSE=""
15
16 need_httpd_cgi
17
18 pkg_setup() {
19         webapp_pkg_setup
20         elog "Note that file locations have changed."
21         elog "CGI:IRC will be installed into cgi-bin/${P}"
22 }
23
24 src_unpack() {
25         unpack ${A}
26         cd "${S}"
27         ecvs_clean
28 }
29
30 src_install() {
31         webapp_src_preinst
32
33         local docs="README cgiirc.config.full ipaccess.example"
34
35         dodoc docs/{CHANGES,TODO} ${docs}
36         dohtml docs/help.html
37         rm -rf docs/ ${docs}
38
39         insinto "${MY_CGIBINDIR}"/${P}
40         doins -r .
41         fperms +x "${MY_CGIBINDIR}"/${P}/irc.cgi
42
43         webapp_configfile "${MY_CGIBINDIR}"/${P}/cgiirc.config
44         webapp_src_install
45 }