dev-python/pytest: arm64 stable (bug #723996)
[gentoo.git] / net-im / yowsup / yowsup-3.2.3_p20190905.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 DISTUTILS_USE_SETUPTOOLS="bdepend"
7 EGIT_COMMIT="2adc067f306d9e7d8b634f66e96c52d80a42e1ff"
8 PYTHON_COMPAT=( python3_{6,7,8} )
9 PYTHON_REQ_USE="readline"
10
11 inherit distutils-r1
12
13 DESCRIPTION="A library that enables you to build applications which use the WhatsApp service"
14 HOMEPAGE="https://github.com/tgalal/yowsup"
15 SRC_URI="https://github.com/tgalal/yowsup/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
16
17 LICENSE="GPL-3"
18 SLOT="0"
19 KEYWORDS="amd64 x86"
20
21 RDEPEND="
22         dev-python/appdirs[${PYTHON_USEDEP}]
23         dev-python/configargparse[${PYTHON_USEDEP}]
24         dev-python/consonance[${PYTHON_USEDEP}]
25         dev-python/pillow[${PYTHON_USEDEP}]
26         dev-python/protobuf-python[${PYTHON_USEDEP}]
27         dev-python/python-axolotl[${PYTHON_USEDEP}]
28         dev-python/six[${PYTHON_USEDEP}]
29 "
30
31 DEPEND="${RDEPEND}"
32
33 S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
34
35 PATCHES=( "${FILESDIR}/${PF}-fix-install-path.patch" )
36
37 src_prepare() {
38         default
39
40         # After talking to upstream, version restriction can be lifted
41         # and also 'argparse' needs to be removed.
42         sed -e 's/==0.1.3-1//' -e 's/==0.2.2//' -e 's/==1.10//' -e 's/argparse//' -i setup.py || die
43 }
44
45 pkg_postinst() {
46         einfo "Warning: It seems that recently yowsup gets detected during registration"
47         einfo "resulting in an instant ban for your number right after registering"
48         einfo "with the code you receive by sms/voice."
49         einfo "See https://github.com/tgalal/yowsup/issues/2829 for more information."
50 }