dev-python/elementpath: arm64 stable (bug #723996)
[gentoo.git] / net-im / poezio / poezio-9999.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_6 )
6
7 inherit distutils-r1 readme.gentoo-r1
8
9 DESCRIPTION="Console XMPP client that looks like most famous IRC clients"
10 HOMEPAGE="https://poez.io/"
11 LICENSE="ZLIB"
12 SLOT="0"
13
14 if [[ "${PV}" == "9999" ]]; then
15         EGIT_REPO_URI="https://lab.louiz.org/${PN}/${PN}.git"
16         inherit git-r3
17 else
18         SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
19         KEYWORDS="~amd64"
20 fi
21
22 RDEPEND="
23         dev-python/aiodns[${PYTHON_USEDEP}]
24         dev-python/pyasn1-modules[${PYTHON_USEDEP}]
25         dev-python/pyasn1[${PYTHON_USEDEP}]
26         dev-python/slixmpp[${PYTHON_USEDEP}]
27 "
28
29 distutils_enable_tests pytest
30
31 DOC_CONTENTS="
32 Install these optional runtime dependencies for additional features.
33 * dev-python/potr for OTR encryption support.
34 * dev-python/pyinotify for screen autoaway plugin support.
35 "
36 DISABLE_AUTOFORMATTING=true
37
38 src_prepare() {
39         default
40         # Delete unmaintained plugin which requires an excessive external dep
41         rm plugins/mpd_client.py || die
42 }
43
44 src_install() {
45         distutils-r1_src_install
46         readme.gentoo_create_doc
47 }
48
49 pkg_postinst() {
50         readme.gentoo_print_elog
51 }