sys-process/glances: revbump 3.1.4.1, add missing doc dep
[gentoo.git] / net-im / centerim / centerim-5.0.1.ebuild
1 # Copyright 1999-2018 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="6"
5
6 MY_P="${PN}5-${PV/_}"
7
8 DESCRIPTION="CenterIM is a ncurses ICQ/Yahoo!/AIM/IRC/MSN/Jabber/GaduGadu/RSS/LiveJournal Client"
9 SRC_URI="http://www.centerim.org/download/cim5/${MY_P}.tar.gz"
10 HOMEPAGE="http://www.centerim.org/"
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="amd64 x86"
14 IUSE="debug nls"
15
16 DEPEND=">=sys-libs/ncurses-5.2:=
17         >=net-im/pidgin-2.7.0
18         >=dev-libs/glib-2.16.0
19         >=dev-libs/libsigc++-2.2.0"
20 RDEPEND="${DEPEND}
21         nls? ( sys-devel/gettext )"
22 DEPEND="${DEPEND}
23         virtual/pkgconfig"
24
25 S="${WORKDIR}"/${MY_P}
26
27 src_configure() {
28         econf \
29                 $(use_enable debug) \
30                 $(use_enable nls)
31 }
32
33 src_install() {
34         emake DESTDIR="${D}" install
35         rm -f "${D}"/usr/lib*/libcppconsui.{a,la}
36
37         dodoc AUTHORS HACKING NEWS README TODO
38 }